Modbus TCP doesn't work anymore

Topics about the Software of Revolution Pi
Post Reply
User avatar
MikeStern
Posts: 11
Joined: 29 Aug 2022, 13:26

Modbus TCP doesn't work anymore

Post by MikeStern »

Hi,
after i had reset the mac address if my RevPi Compact with the command " sudo revpi-factory-reset compact 81919 C83E-A710-253D",
my modbus TCP ttyRS485 interface it doesn't work anymore.

at prompt also i receive this message
pi@RevPi81919:~ $ piTest -r Modbus_Master_Status
Cannot find variable 'Modbus_Master_Status'


How i can fix it ?

Regards.
Mike
EkoGreenPower.com
Online
User avatar
dirk
KUNBUS
Posts: 2042
Joined: 15 Dec 2016, 13:19

Re: Modbus TCP doesn't work anymore

Post by dirk »

Hello Mike, maybe you need to do a PiCtory configuration. So you have to log in to the WebStatus interface and drag and drop your RevPi Compact Module from the left side to the DIN rail on the right side. Then file -> save as default and Tools -> reset driver.
I hope that does it!
User avatar
MikeStern
Posts: 11
Joined: 29 Aug 2022, 13:26

Re: Modbus TCP doesn't work anymore

Post by MikeStern »

Hi,
i cant log-on on web interface... the password doesn't work ! ( i never changed it)
How i can restore or reset the password of the web interface?

Thanks
Mike
EkoGreenPower.com
Online
User avatar
dirk
KUNBUS
Posts: 2042
Joined: 15 Dec 2016, 13:19

Re: Modbus TCP doesn't work anymore

Post by dirk »

Ouch, ok, so the quickest way is to restore the factory settings using the steps in this checklist:
Revolution Pi Checklist
User avatar
MikeStern
Posts: 11
Joined: 29 Aug 2022, 13:26

Re: Modbus TCP doesn't work anymore

Post by MikeStern »

Hi,
good news! :)
i have solved the problem!
the command that i have used to change the mac address "sudo revpi-factory-reset compact 81919 C83E-A710-253D" was wrong!
the right command tha i had to use is "sudo revpi-factory-reset connect 81919 C83E-A710-253D" because i have a RevPi Connect model not the Compact!

All work fine !

Thanks
Mike
EkoGreenPower.com
Online
User avatar
dirk
KUNBUS
Posts: 2042
Joined: 15 Dec 2016, 13:19

Re: Modbus TCP doesn't work anymore

Post by dirk »

Ah perfect, good to hear that you could solve it, never mind that happens ;)
Post Reply