kulo9
Topic Author
Posts: 8
Joined: 24 Nov 2021, 16:35
Answers: 0

Modbus RTU funktioniert nicht mehr mit Revpi Connect SE

06 Feb 2023, 18:16

Hallo zusammen,
ich habe schon einige Revpi Connect in verschiedenen Projekten verwendet und dabei immer wieder die Modbus RTU Schnittstelle verwendet.
Durch die bekannten Lieferprobleme und die Umstellung auf die neuen Modell hab ich nun einen Revpi Connect SE im Einsatz. Bei diesem Revpi Connect SE habe ich jetzt das Problem, dass ich keine Verbindung zu Modbus RTU Slaves mehr aufbauen kann. Ich habe das Gerät mehrfacht gecheckt, geupdated, die Verkabelung überprüft, neu gestartet, ... aber alles ohne Erfolg. Bei den vorherigen Connect hatte ich damit keine größeren Schwierigkeiten.
Ich habe auch ein weiteren Revpi Connect SE getestet mit dem selben Resultat. Daher habe ich den Verdacht, dass es eventuell an der neuen Variante liegen könnte.

Ich wäre sehr dankbar für Hinweise und Unterstützung um das Problem zu lösen.
Beste Grüße
 
User avatar
dirk
KUNBUS
Posts: 1757
Joined: 15 Dec 2016, 13:19
Answers: 1

Re: Modbus RTU funktioniert nicht mehr mit Revpi Connect SE

07 Feb 2023, 16:29

Hi kulo9,
ich habe soeben einen Test gemacht mit einem Revolution Pi Connect SE Modul und es hat funktioniert:
RevPi Connect Modbus RTU Master.png
RevPi Connect SE Modbus RTU Master
RevPi Connect Modbus RTU Master.png (208.56 KiB) Viewed 1174 times
Wie hast du denn die Inbetriebnahme durchgeführt? Hast du ein aktuelles System / Image verwendet? Was macht denn die Verkabelung ... :)
Bitte prüfe Dein Setup anhand dieser Checklisten nochmals - viel Erfolg
RS-485 Checklist
Revolution Pi Checklist
 
kulo9
Topic Author
Posts: 8
Joined: 24 Nov 2021, 16:35
Answers: 0

Re: Modbus RTU funktioniert nicht mehr mit Revpi Connect SE

06 Mar 2023, 09:50

Hi Dirk,
danke dir erstmal für die Rückmeldung, Links und Vorschläge. Ich habe mir alle Hinweise angeschaut und versucht genau umzusetzen, daher komme ich auch leider etwas spät erst dazu mich wieder zu melden.
Abschließend lässt sich sagen, dass jegliche Ansätze und Versuche erfolglos waren.
Ich habe mittlerweile die Möglichkeit gehabt 3 RevPi Connect SE zu testen, alle mit dem selben Ergebnis, dass ich keine Modbusverbindung herstellen konnte.
Zusätzlich hatte ich auch noch einen "älteren" RevPi Connect von vor ca. 1 Jahr. Bei diesem Gerät habe ich mein ModbusTestgerät elektrisch verbunden und sofort konnten die Daten ausgelesen werden.
Die Verkabelung habe ich dann unverändert wieder auf die 3 RevPi Connect SE gesteckt aber erneut konnte keinerlei Modbusverbindung hergestellt werden.

Ein Problem in der Elektrik/Verkabelung würde ich daher ausschließen. Darüber hinaus habe ich trotzdem den auf Funktion geprüften Aufbau in jeglichen Varianten variiert, ohne Erfolg.
Weiterhin habe ich auch diverse Neustarts, Updates erneut versucht. Der letzte RevpiConnect SE ist noch unverändert wie aus der Verpackung entnommen, kann aber auch keine Verbindung herstellen. Mir fallen keine weiteren Möglichkeiten mehr ein, was ich noch variieren oder probieren kann.

Eine letzte Beobachtung die mir aufgefallen ist war, dass bei den 3 RevPi Connect SE bei aktivem ModbusMaster keine Differenzspannung zwischen A und B zu messen war, bei dem Revpi Connect jedoch schon. Für mein Verständnis sollte das auch der Zustand sein, dass die beiden Signalleitungen eine kleine Spannungsdifferenz haben. Kann es sein, dass hier die Schnittstelle nicht korrekt angesprochen, aktiviert, verwendet wird? Muss/kann der ModbusMaster noch anders aktiviert werden (Hintergrundservices usw.)?

Ich hoffe, dass meine Beschreibungen dich eventuell auf eine Idee bringen und zur Lösung des Problems.
Fallls du noch Informationen oder Daten von mir benötigst stelle ich die gern zur Verfügung.
 
kulo9
Topic Author
Posts: 8
Joined: 24 Nov 2021, 16:35
Answers: 0

Re: Modbus RTU funktioniert nicht mehr mit Revpi Connect SE

30 Mar 2023, 16:13

Hallo Dirk,
ich habe nach wie vor das beschriebene Problem und wollte mich kurz erkundigen, ob sich in der Zwischenzeit noch etwas ergeben hat?
Hast du eine Idee woran es möglicherweise liegt, bzw. was ich noch ausprobieren könnte um das Problem zu beheben.
Danke für deine Rückmeldung.
 
User avatar
stefanh
KUNBUS
Posts: 11
Joined: 05 Apr 2023, 10:53
Answers: 0

Re: Modbus RTU funktioniert nicht mehr mit Revpi Connect SE

13 Apr 2023, 14:16

Hallo kulo9, durch den Wechsel vom RevPi auf den RevPi SE ist es wichtig den Migration-Guide durchführen - den findest du hier: https://revolutionpi.com/tutorials/migration-cm4s/

Wenn das nicht hilft, kannst du uns bitte einen SOS Report schicken, an support@kunbus.com.

Gruß Stefan FAE KUNBUS

Who is online

Users browsing this forum: No registered users and 4 guests