anth
Topic Author
Posts: 3
Joined: 29 Jul 2023, 19:27
Answers: 0

RevPi Node Pin select not loading

29 Jul 2023, 19:51

Hi all,

Trawled the web for a solution to this and tried everything suggested (Updated everything, checked server version, disabled pyLoad) but can't find a solution.

I can connect to the server and read pins when manually passing the payload, but I need to be able to output.
Image

Some stuff to point out, the way I have this setup is instead of the pictory node-red server, I have a flowforge-device-agent running on the RevPi and communicating with the server that way. It's all done via localhost so shouldn't be an issue and it can actually connect ok, just the list is causing me issues.

My current workaround is configuring the node in JSON and importing it, this seems to work but its a bit annoying.
Image

Any help on this will be greatly appreciated

Image
 
anth
Topic Author
Posts: 3
Joined: 29 Jul 2023, 19:27
Answers: 0

Re: RevPi Node Pin select not loading

02 Aug 2023, 14:24

Anyone?
 
anth
Topic Author
Posts: 3
Joined: 29 Jul 2023, 19:27
Answers: 0

Re: RevPi Node Pin select not loading

03 Aug 2023, 23:30

Ok I'm answering my own questions here but It's been driving me mad. I THINK its got something to do with the default config not allowing external connections. I ran both the flowforge agent and a local node-red instance, the local instance has access to the pins just fine. I'll get a config allowing remote comms and user/pass in there and see if that sorts it, will report back.

Who is online

Users browsing this forum: No registered users and 0 guests