Node-red on two Pis same network- slow comms

Post Reply
kartheek
Posts: 6
Joined: 29 Mar 2019, 01:12

Node-red on two Pis same network- slow comms

Post by kartheek »

I configured two Rev Pis with different IP addresses. both are on the same network. When i ssh into either of the Pis or open the node page, they get really slow. A letter typed in putty takes 20 seconds.

Individually, they are fast. but both on the same network even with different IPs create a problem. Any suggestions to fix this.
User avatar
dirk
KUNBUS
Posts: 2001
Joined: 15 Dec 2016, 13:19

Re: Node-red on two Pis same network- slow comms

Post by dirk »

Hi kartheek, this seams strange. Please send the "kern.log" files of the devices so that we can analyze the root cause. A Wireshark trace would also be welcome.
User avatar
Marcos
Posts: 17
Joined: 09 Mar 2020, 18:42

Re: Node-red on two Pis same network- slow comms

Post by Marcos »

Hi,
I'm interested in this topic.
Do you have any news about the investigations?
Marco
login721
Posts: 5
Joined: 12 Nov 2019, 01:30

Re: Node-red on two Pis same network- slow comms

Post by login721 »

Just my guest but can you check if they MAC address is different? I once deploy a few pi based on the same backup image, forgot to run the factory-reset that cause multi device with the same MAC in the local network.
kartheek
Posts: 6
Joined: 29 Mar 2019, 01:12

Re: Node-red on two Pis same network- slow comms

Post by kartheek »

Dirk,

Can you please guide me how to get the logs.

Additional info:
I loaded the two pis with the same image.. When i am putting the two pis on the same network, i go to "/etc/dhcpcd.conf" file and change the static IP. Both have different IPs.
MAC addresses are different
User avatar
dirk
KUNBUS
Posts: 2001
Joined: 15 Dec 2016, 13:19

Re: Node-red on two Pis same network- slow comms

Post by dirk »

Hello, please excuse the long delay. I have moved your topic to the Node-RED forum. I hope that the experts from erminas may support you.
Post Reply