Picotry insecure connection

Topics about the Software of Revolution Pi
Post Reply
in06khattab
Posts: 40
Joined: 24 Jan 2024, 19:07

Picotry insecure connection

Post by in06khattab »

When I access pictory, it redirects me to http://192.168.255.1:41080/insecure_connection.html
Screenshot_8.jpg
It then redirects to this webpage which cannot be reached
https://192.168.255.1:41443/
Screenshot_7.jpg
I noticed the port changed from 41080 to 41443

I have recently upgraded from buster to bullseye which I know is not recommended. I was wondering if you had any ideas how to fix it?
User avatar
nicolaiB
KUNBUS
Posts: 897
Joined: 21 Jun 2018, 10:33
Location: Berlin
Contact:

Re: Picotry insecure connection

Post by nicolaiB »

You are probably missing the correct webserver configuration:

eg. /etc/apache2/sites-enabled/revpi-ssl-site.conf

Code: Select all

<IfModule mod_ssl.c>
        Listen 41443
        <VirtualHost _default_:41443>
                ServerAdmin webmaster@localhost

                DocumentRoot /var/www/revpi

                ErrorLog ${APACHE_LOG_DIR}/revpi/error.log
                CustomLog ${APACHE_LOG_DIR}/revpi/access.log combined

                # Include all files and directories for webstatus and pictory to allow access to
                php_admin_value open_basedir "\
/etc/timezone:\
/usr/bin/date:\
/usr/bin/piControlReset:\
/usr/bin/sudo:\
/usr/bin/uptime:\
/usr/sbin/piSerial:\
/var/www/revpi"

                SSLEngine on

                SSLCertificateFile      /etc/ssl/certs/revpi-self-signed.pem
                SSLCertificateKeyFile   /etc/ssl/private/revpi-self-signed.key

                <FilesMatch "\.(cgi|shtml|phtml|php)$">
                        SSLOptions +StdEnvVars
                </FilesMatch>

                <Directory /usr/lib/cgi-bin>
                        SSLOptions +StdEnvVars
                </Directory>

        </VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

in06khattab
Posts: 40
Joined: 24 Jan 2024, 19:07

Re: Picotry insecure connection

Post by in06khattab »

I have progressed by following the instructions here https://kunbus-gmbh.atlassian.net/wiki/ ... ullseye%3F and here https://kunbus-gmbh.atlassian.net/wiki/ ... Stretch%3F

I can now access pictory. I now get a certificate error. Is that expected?

I still see this website:
Screenshot_8.jpg
Then it redirects to here:
Screenshot_9.jpg
Then I see this:
Screenshot_10.jpg
Is this expected?
in06khattab
Posts: 40
Joined: 24 Jan 2024, 19:07

Re: Picotry insecure connection

Post by in06khattab »

Code: Select all

cat  /etc/apache2/sites-enabled/revpi-ssl-site.conf
<IfModule mod_ssl.c>
        Listen 41443
        <VirtualHost _default_:41443>
                ServerAdmin webmaster@localhost

                DocumentRoot /var/www/revpi

                ErrorLog ${APACHE_LOG_DIR}/revpi/error.log
                CustomLog ${APACHE_LOG_DIR}/revpi/access.log combined

                # Include all files and directories for webstatus and pictory to allow access to
                php_admin_value open_basedir "\
/etc/timezone:\
/usr/bin/date:\
/usr/bin/piControlReset:\
/usr/bin/sudo:\
/usr/bin/uptime:\
/usr/sbin/piSerial:\
/var/www/revpi"

                SSLEngine on

                SSLCertificateFile      /etc/ssl/certs/revpi-self-signed.pem
                SSLCertificateKeyFile   /etc/ssl/private/revpi-self-signed.key

                <FilesMatch "\.(cgi|shtml|phtml|php)$">
                        SSLOptions +StdEnvVars
                </FilesMatch>

                <Directory /usr/lib/cgi-bin>
                        SSLOptions +StdEnvVars
                </Directory>

        </VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

It is the same as yours.
in06khattab
Posts: 40
Joined: 24 Jan 2024, 19:07

Re: Picotry insecure connection

Post by in06khattab »

Now I see this, but it all seems ok
Attachments
Screenshot_11.jpg
Post Reply