dpfeil
Topic Author
Posts: 6
Joined: 13 Apr 2021, 13:32
Answers: 0

How to deactivate network interface pileft

16 May 2023, 14:25

Hello,

I have a RevpiConnect (RevPi Buster (08/2022)) with two network interfaces "eth0" and "eth1".
But "ip link show" says there is also an "pileft" network interface.
The problem with "pileft" is that the MAC address of this interface changes after each reboot. And this causes teamviewer to change the teamviewer ID after each reboot. So teamviewer is useless for me, as I have to input the login credentials after each reboot. Teamviewer support says the MAC address change of the virtual "pileft" network interface causes the teamviewer ID change.
Does anybody know how to deactivate the "pileft" network interface?

BR
Daniel
 
Nicolas
Posts: 1
Joined: 25 May 2023, 21:13
Answers: 0

Re: How to deactivate network interface pileft

25 May 2023, 21:14

I have the same problem. This is problematic.
 
kjkoster
Posts: 85
Joined: 12 Feb 2022, 10:42
Answers: 2

Re: How to deactivate network interface pileft

27 May 2023, 12:34

Dear all,

This seems to be a general complaint about Teamviewer, based on what people post on their forums. Other remote desktop systems work fine without such limitations (e.g. VNC, but there are plenty others). Many computer systems have dynamic MAC addresses nowadays. If you run any form of VPN virtualisation you get a whole slew of extra network interfaces for the containers.

Teamviewer seems to be lacking the option to bind to a specified network interface. I think the robust solution here is for Teamviewer honour their customer's request to add the option to bind their client to a specific interface. There is a feature request on their forums. That, or for you to switch to an open source Teamviewer alternative.

Kees Jan
 
User avatar
stefanh
KUNBUS
Posts: 12
Joined: 05 Apr 2023, 10:53
Answers: 0

Re: How to deactivate network interface pileft

30 May 2023, 13:39

Hello,

I have a RevpiConnect (RevPi Buster (08/2022)) with two network interfaces "eth0" and "eth1".
But "ip link show" says there is also an "pileft" network interface.
The problem with "pileft" is that the MAC address of this interface changes after each reboot. And this causes teamviewer to change the teamviewer ID after each reboot. So teamviewer is useless for me, as I have to input the login credentials after each reboot. Teamviewer support says the MAC address change of the virtual "pileft" network interface causes the teamviewer ID change.
Does anybody know how to deactivate the "pileft" network interface?

BR
Daniel
Hi Daniel,

the network interface pileft is the internal bus system of the RevPi system, it is not recommended to disable this. I could reproduce that with the changing MAC address after each reboot. Unfortunately, we have no control over the actions of software like Teamviewer. But you can set a static MAC for the interface pileft.

Edit the config file:
 /boot/config.txt (below ):
pileft_mac_hi=0x<first 4 bytes>
pileft_mac_lo=0x<last 2 bytes> 

Or use this bash script: https://gist.github.com/nbuchwitz/65835 ... 023a19b63a


Best regards
Stefan

Who is online

Users browsing this forum: Semrush [Bot] and 1 guest