Topic Author
Posts: 1
Joined: 15 Mar 2023, 09:50
Answers: 0

CodeSys OPC UA connection not possible - Error: BadUserAccessDenied

15 Mar 2023, 10:21

Good day,

I have a Connect+ device running paid license of CodeSys MC SL.
I’ve been trying to configure an OPC UA server for anonymous access. (User access with password has also not worked...)
I’ve followed suggestions on different forums (including this forum) but I’m still not able to establish a connection with the server using UaExpert or Node-RED.

The error I receive on UaExpert is:
09:36:10.941 | Server Node | OPCUAServer@RevPi87022 | Used UserTokenType: Anonymous
09:36:10.979 | Server Node | OPCUAServer@RevPi87022 | Error 'BadUserAccessDenied' was returned during ActivateSession
09:36:10.983 | Server Node | OPCUAServer@RevPi87022 | Connection status of server 'OPCUAServer@RevPi87022' changed to 'Disconnected'.
Thus far I’ve disabled the User Management on Codesys and allowed for Anonymous access via the Codesys Runtime security. ( ... mous+login)
I’ve also allowed the certificates for connections via UaExpert and Node-RED (following these instructions: ... ua_server/)

I also tried changing the Codesys config files based on the suggestions listed here: ... 3a0b4a227/

Any help with the issue would be greatly appreciated!!!
Posts: 142
Joined: 14 Apr 2022, 13:04
Answers: 1

Re: CodeSys OPC UA connection not possible - Error: BadUserAccessDenied

03 Apr 2023, 10:14

Hello Johan.vdw,

The error you have on UaExpert is due to the configuration on your server side. You are running OPCUA Server in codesys.
Please have a look at this OPCUA&CODESYS webinar.
you can also post your problem on Codesys forum.

Best Regards

Ulrich Kouatang Biakoup | Technical Support

Who is online

Users browsing this forum: No registered users and 0 guests